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Abstract

This Quick Start Guide will help to introduce you with LibreCAD. If you have no experience of
CAD before, then its a right place to start. This tutorial will make you familiar with many CAD
concepts and it will also tell you how to use various functions and commands in LibreCAD. You
need to keep patience while reading and enjoy the tutorial.
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1 Basics of CAD

Entities

Entities are graphical objects in a CAD system. Typical entities which are supported by most
CAD systems are: points, lines and circular and elliptical arcs. More complex and CAD specific
entities include polylines, texts, dimensioning, hatches and splines.

Layers

A basic concept in computer aided drafting is the use of layers to organize a drawing. Every entity
in a drawing is on exactly one layer and a layer can contain lots of entities. Typically entities with
a common ’function’ or common attributes are put on the same layer. E.g. you might want to put
all axes in a drawing on a layer named ‘axes’. Layers can have their own attributes also (colour,
line width, line style etc...). Each entity can have its own attributes or have its attributes defined
by the layer it is placed on. In the latter case for example you can change the colour of all the
entities on the “axes” layer by setting the colour (red for example) for the layer ‘axes’.

Blocks

A Block is a group of entities. Blocks can be inserted into the same drawing more than once with
different Attributes and at different locations and at a different scale and rotation angle . Such an
instance of a block is usually called an Insert. Inserts have attributes just like entities and layers.
An Entity that is part of an Insert can have its own attributes or share the attributes of the Insert.
Once created, Inserts are still linked to the Block they instantiate. The power of inserts is, that
you can modify the Block once and all Inserts will be updated accordingly.

Coordinate System

In order to get the best out of LibreCAD it is wise to have a good understanding of the coordinate
system and how coordinates work. Everything that you draw in LibreCAD will be exact and pre-
cise and will be placed there accurately based on the X,Y coordinate system. The absolute origin
or Zero point in your drawing is where the X and Y axes cross each other (represented by a Red
cross), every entity you draw is located in relation to this origin.
In LibreCAD there is also the option to set the Relative Zero Point (small red circle).This Relative
zero point can be temporarily set to a new location in a drawing so that all subsequent X and Y
coordinates of entities drawn or blocks placed for example will be relative to this newly set Relative
Zero Point.
In LibreCAD’s 2D coordinate system all X units are measured horizontally and all Y units are
measured vertically. Coordinates can also be shown as ‘Positive’ (+) or ‘Negative’(-) values.
Basically there are two types of Coordinates Cartesian and Polar. The Cartesian coordinate
system is generally the standard system used in most CAD programs. A specific point in a draw-
ing is located by exact distances from both the X and Y axes - for example a point in a drawing
could be 60,45 (note the comma -, separates the two numbers).
The Polar coordinate system uses one distance and one angle to define a point in a drawing
-for example a point in a drawing could be 50 < 45, so 50 units long and at an angle of 45 degrees
(note the < sign is used for the angle).

In LibrecAD lines,points, Arcs, Polylines, Circles and many more entities can be drawn and placed
in a drawing using either Absolute or Relative coordinate input.
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Absolute coordinates - using this method,coordinate points are entered in direct relation to the
Origin 0,0. To do this in LibreCAD just enter in the exact point e.g. 60,45.
Relative coordinates - using this method, coordinate points are entered in relation to the pre-
vious point entered (not the origin), so for example - if your first point is 20,45, to then enter
your next point ‘relative’ to this - you would use the ‘@’ symbol - e.g @50,50 would then enter the
second point 50 units horizontally along the x axis and 50 units vertically along the Y axis to give
this second point relative to your last point (20,45).

Dimensioning

Required sizes of objects within a drawing are conveyed through the use of dimensions. Dimen-
sion ‘distances’ may be shown with either of two standardized forms of dimension - Linear and
ordinate.
Linear dimensions use two parallel lines - called “extension lines,” which are spaced at the ‘re-
quired’ distance between two given points.A line perpendicular to these extension lines is called a
“dimension line”, with arrows at its endpoints. The numerical indication of the distance is placed
at the midpoint of the dimension line, adjacent to it or in a gap provided for it!
Ordinate dimensions use one horizontal and one vertical extension line to establish an origin
for the entire view. The origin is identified with 0,0 placed at the ends of these extension lines.
Distances along the x and y axes to other points on a drawing are indicated using additional
extension lines with numerical information placed appropriately.
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2 Introduction to LibreCAD

What is LibreCAD?

LibreCAD is a free, open source 2D CAD software for Windows, Apple, Linux. It is released under
the license of GNU General Public License(GPL v2).

Why LibreCAD?

It is a CAD software used to create 2D drawings. It has many fascinating features that would help
you to add more details to your drawings. It is a perfect 2D CAD software and is light weighted.
It is available for Windows, Apple, Linux.

I am new to LibreCAD, How could I start?

If you are new to CAD, don’t worry, this notes will help you to learn some CAD concepts too.
This quick start notes will help you to start creating drawings in LibreCAD quickly.

Getting familiar with User Interface

LibreCAD has an interactive user interface. One can easily get familiar with it.

Figure 1: User Interface of LibreCAD
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LibreCAD window is divided into eight areas:

1. Menubar

2. Toolbar

3. Model Space

4. Layer Selection Box

5. Command Line

6. Status Line

7. Layer List

8. Block List

Figure 2: LibreCAD Screen

Menu Bar: A horizontal menu located on top that contains the major functions of CAD. When
a function is selected from the menu, the menu drops down and displays further options under
the menu. A number of options in the menu bar allows you to set program defaults and create a
customized working environment.

Toolbar: A collection of tool buttons grouped together. It is on the left side of the drawing
window. Using tool bars is a very convenient method of entering commands, because you don’t
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need to type on the keyboard or navigate through the menus. Each command is represented with
a specific tool button in the tool bar. To enter a command, all you need to do is click on the tool
button with the help of pointing device. It has nested toolbar in it. If you select circle, then it
will display a varity of circles under a ‘circle’ category. There is also a toolbar below the menu
bar, which contains some common functions. LibreCAD allow you to customize the toolbars as
needed. You can place frequently used tool buttons in a tool bar, display only specific tool bars,
and arrange them on the screen as you like.

Model space/Drawing window: The Drawing window or Model space is the area where you
create your drawing. All the drawing work is confined within this area. The drawing window
may look small, but it has infinite size like the sky. You can draw as big or as small on this sky
like drawing window. The view-display functions allow you to display specific views of the drawing.

Layer Selection Box: Layer Selection Box helps in selecting the Layer’s atributes like: color,
line type, thinkness.

Command Line: It is used to type commands. It notify you warnings or errors, if something
is wrong. An area on the screen that shows all the commands being entered. You just need to
remember the command names and type in command window to perform its function. Like, if you
want to draw circle, then type ‘circle’ in command window, it will ask you to enter the coordinates
where to draw circle and with what radius.
Working with command window is fast and accurate method to draw. But you have to remember
the command names to perform its function. These commands also has short commands, like to
draw line, you can type ’line’, ’ln’ or ’l’

Status Line: The bottom bar of your screen which shows status of LibreCAD. Shows settings
associated with the current drawing on the screen. It shows absolute and relative position of your
mouse in cartesian and in polar coordinates. The mouse widgets shows the status of mouse left and
right button. The ‘Selected Entities’ shows you number of entities you selected. To enable/disable
status bar, goto menu: view > status bar.

Layer/ Block List: It is on the right side of the drawing window. It shows the Layers and
Blocks of currently opened Drawing.
Layers are used to keep same type of attributes in one layer. we can toggle the layers i.e to change
the layers visible to hidden or vice-versa.
Blocks are used to use the block of a drawing, many times in our drawing.

Ways to communicate with LibreCAD:

• Using the Menu Bar.

• Using the tool bars.

• Entering commands in the command window.

• Working in the drawing area.
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Checking Version of LibreCAD:

It is important to check version of LibreCAD before starting work. LibreCAD version shoud be
>=v2.0.* If you have LibreCAD version less than this, then kindly switch to latest version as, the
old version contains some bugs. To check the version of your Application. Goto Help menu >
Select About. Ensure here the version of LibreCAD you using.

Figure 3: About LibreCAD
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3 Preparing for Drawing

1. Setting the units: You can set the units for your drawing from Edit Menu.

Figure 4: Edit menu

You can either set your changes as a whole or for a current drawing. If you make changes in
Application Preferences, then these changes will reflect to your whole application. And
If you make changes in Current Application Prefences, then the changes reflect to your
current Drawing only.

To set changes in your Current Drawing:

(a) Click on the Edit Menu

(b) then click on Current Drawing Preferences

Figure 5: Current Drawing Preference

(c) Goto Units tab,The units command allows setting the type of measurement and orien-
tation of angular measurement.

(d) Select the Main Drawing unit. By default, it is set to Millimeter.
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(e) Set the Format. There are different formats: Architectural, Decimal, Engineering,
Fractional, Scientific.

Figure 6: Setting the Format for Length.

2. Snap and grid mode: Grid and Snap mode are used to learn, to restrict the movement of
the cursor to a set increment on the screen. The GRID and SNAP MODE options can be
turned ON or OFF from the icons or menubar or command line.
Snap feature allows you to precisely select grid points or significant points on existing objects:
endpoints or midpoints of lines, etc. You can select snap option under ’Snap’ Menu or from
icons or from command line. Below is this image of icons of different type of snapping.

Figure 7: Icons for Snapping

Figure 8: Choosing the type of Grid.
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The Grid : A grid usually refers to two or more infinite sets of evenly-spaced parallel
lines at particular angles to each other in a plane, or the intersections of such lines. It helps
you align objects and visualize the distance between them. You can also change the color of
Grid from Edit menu > Application Prefences > Grid color.
There are two types of grid: orthogonal grids, with two sets of lines perpendicular to each
other (such as the square grid), and isometric grids, with three sets of lines at 60-degree
angles to each other (such as the triangular grid). Isometric grid is used to depict 3D objects
on a 2D surface.You can select type of Grid you want from Edit menu > Current Drawing
Preferences.

3. Zooming and panning: Pan and zoom are very useful tools in LibreCAD. We can use
Zoom or Pan command to navigate in our drawing.

Figure 9: Icons for Zooming and Panning

Zoom: This tool increases / decreases the current viewing factor. The zoom tool is valuable
when you need to move up close to an entity to work on it. This is especially true when
the area is very small, or several lines drawn close together. As you will see in a moment,
there are several ways to use zoom: Zoom In, Zoom out, Auto Zoom, Window Zoom, Zoom
panning.
Panning: Panning means moving around the drawing. Selecting the panning option you
can drag your drawing. Pan allows you to dragging the drawing up, down, right, or left.
This is especially useful if your drawing is large.

4. Dimentioning: To make changes in your application, goto ‘Application prefernces’ under
‘Edit’ menu. If you want to make changes in current drawing only, then goto to Edit >
Current Preference. Then selects the Dimensions tab.

Figure 10: Dimensioning
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Figure 11: Setting Dimensioning for Drawing.

5. Layers: Every entity of a drawing is on exactly one layer and a layer can contain lots of
entities. Typically entities with a common ’function’ or common attributes are put on the
same layer. Layers are especially important in Assembly drawings. An Assembly drawing is
a drawing showing 2 or more parts as an assembly on a drawing. Each part is drawn on its
own layer and when all the layers are shown on the drawing you have the complete assembly
in view. You can create/ delete as much layers as you want, but their must be atlest one
layer in drawing. By default there is one layer created, named ‘0’. Layers can have attributes
(color, line width, line style). Each entity can have its own attributes or have its attributes
defined by the layer it is placed on.

Figure 12: Icons for Layer

• Line color: You can select the color for your layer. This color will be same for all
entities on a current Layer.

• Line width: You can select the width of line you want to use for your current layer.

• Line type: It provides you different types of lines: Dot, Dashed, Continous, Divid,
Center, Border, No pen, etc.

Jasleen Kaur: Quick Start Guide to LibreCAD 11



LibreCAD

4 Using Command Line

DRAW Command

Point po, point
Line l, li, line

Polyline polyline
LineParallel o, offset, par, parallel

Arc3P a, arc
Circle ci, circle

LineRectangle rec, rectang, rectangle
Text text

ZOOM Command

ZoomRedraw zr, rg, regen, zoom - redraw
ZoomWindow zw, zoom - window

ZoomAuto za, zoom - auto
ZoomPan zp, zoom - pan

ZoomPrevious zv, zoom - previous

EDIT Command

EditUndo u, undo
EditRedo r, redo

EditKillAllActions k, kill

MODIFY Command

ModifyTrim xt, rm, modify - trim (extend)
ModifyTrim2 tm, modify - multi trim (extend)
ModifyMove mv, modify - move
ModifyBevel ch, modify - bevel (chamfer)
ModifyMirror mi, modify - mirror
ModifyRotate ro, modify - rotate
ModifyScale sz, modify - scale

ModifyStretch ss, modify - stretch
ModifyDelete er, modify - delete (erase)

EditUndo oo, modify - undo (oops)
EditRedo uu, modify - redo

BlocksExplode xp, modify - explode

TOOL Command

ToolRegenerateDimensions dimregen
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DIMENSION Command

DimAligned da, dimension - aligned
DimLinear dr, dimension - linear

DimLinearHor dh, dimension - horizontal
DimLinearVer dv, dimension - vertical

DimLeader ld, dimension - leader

SNAP Command

SnapFree os, snap - none
SnapGrid sg, snap - grid

SnapEndpoint se, snap - end
SnapIntersection si, snap - intersection

SnapCenter sn, snap - center
SnapMiddle sm, snap - middle

SnapOnEntity np, snap - nearest point

SELECTION Command

DeselectAll tn, deselect - all
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5 Play with LibreCAD

Draw some basic

1. Draw a Point:

(a) Goto to toolbar, click on Point icon

(b) Click on Drawing area where you want to create point.

2. Draw a Line:

(a) Goto to toolbar, click on Line icon

(b) A nested toolbar opens, which show you different functions for creating a line. Choose

the Line with two points

(c) Select first point on drawing area

(d) Select second point on Drawing area

3. Draw a Arc

(a) Goto to toolbar, click on Arc icon

(b) A nested toolbar opens, which show you different functions for creating an arc. Choose

the Arc with center, point, Angles

(c) Specify a point on Drawing area as a center of an arc. Hold the left click and move your
cursor. You will see a preciew of circle as you move your cursor. Left click to unhold
the cursor.

(d) Select two points: first point as your Starting point of Arc and second point as your
End point of Arc.

4. Draw a Circle

(a) Goto to toolbar, click on Circle icon

(b) A nested toolbar opens, which show you different functions for creating an Circle.

Choose the Circle with center, point

(c) Specify a point on Drawing area as a center of an arc. Hold the left click and move your
cursor. You will see a preciew of circle as you move your cursor. Left click to unhold
the cursor.
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5. Draw a Ellipses

(a) Goto to toolbar, click on Ellipses icon

(b) A nested toolbar opens, which show you different functions for creating an Ellipses.

Choose the Ellipse with center and 2 points

(c) Specify a point on Drawing area as a center of an arc. Hold the left click and move your
cursor. You will see a preciew of ellipse as you move your cursor. Left click to unhold
the cursor.

6. Draw a Polyline

(a) Goto to toolbar, click on Polyline icon

(b) A nested toolbar opens, which show you different functions for creating an Polyline.

Choose the Create Polyline

(c) Click on one point on drawin are and then second point and then third...and so on till
you want. To come out of this command, use Right click

7. Draw a Spline

(a) Goto to toolbar, click on Spline icon

(b) Define the points to which Spline go through. To come out of this command, use Right
click

8. Draw a Text

(a) Goto to toolbar, click on Text icon

(b) A dialog box will appear. Write the text you want on Dialog box and Set your text’s
font size and style. Then click on OK button

(c) Specify the point on Drawing Area where you want to place your Text.

9. Draw a Image

(a) Goto to toolbar, click on Image icon

(b) Select a image you want by browsing the images from your system

(c) select the point on drawing area where you want to place your image.
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10. Draw a Hatch

(a) Goto to toolbar, click on Text icon

(b) Select the closed entity which you want to hatch.

(c) click on run button

(d) A dialog box will be opened, select the type of hatch and set the angle, and then click
OK button.
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6 Lets Draw Something

6.1 Lets Create a Yard

Preparing for drawing:

• Setting the Units: Goto to Edit menu > Current Drawing Preference, goto Tab Unit >
select Inch as main Drawing units. Also select Archtectural as a Format of unit.

Figure 13: Setting Units for Yard

• Turning ON Grid: Goto to Edit menu > Current Drawing Preference, goto Tab Grid >
check the Show Grid Option > select Orthogonal Grid.

Figure 14: Setting Grid for Yard
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• Turning ON Snap: Goto Snap menu > select Snap on Grdi for an instance. Snapping
will be choosen to find accurate position according to the situation.

Figure 15: Setting Grid for Yard

Creating Layers:

On the Right side of screen, there is a Layer List, which is used to add/edit layers. Create a new
Layer with + icon. Add name of Layer and select its attributes.
Create these layers for Yard Drawing with following Colors and LineType.

Figure 16: Creating Layers
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Name Color Line Type
House White Continous
Lawn Magenta Continous
Lot Blue Dash

Plant Green Continous
Pond Cyan Continous
Road Red Continous

Dimension others(pink) Continous

Save the Drawing:

Now you can save your Drawing. Goto File menu > Save as.
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Start Creating Drawing:

1. Make the Lot Layer active to Drawing Area, from Layer List.

2. Start Drawing with Line. Type ‘li’ (shorthand for line) in Command Line. It will promp
you:

Specify First point: 40,40

Specify next Point: @116<0

Specify next Point: @80<90

Specify next Point: @76<180

Specify next Point: @50<216.88

Specify next Point: @40,40

Single Right Click is used to come out of Line Command. Here points are given as polar
coordinates or cartesian coordinates
(40,40) is a cartesian coordinate, which (x,y) point with respect to absolute value(0,0).
@116<0 is a polar coordinate, where, ‘@’ is to use Relative cordinates, ’116’ is Distance in
inch from previous end point, ”<’is to draw angle, ’0’ is the degree of angle by line is drawn.

Figure 17: Creating Lot of yard Drawing

Now Lot is created, save your drawing as - File > Save.

3. Make the House Layer active to Drawing Area, from Layer List.

4. Select polyline entity by typing polyline in a Command Line.
Turn on Snap on end point.

Specify First point: <Pick lower Right corner of ’Lot’ using snap on endpoint>

Specify next Point: @30<90

Specify next Point: @3<0

Specify next Point: @20<90

Specify next Point: @28<180

Specify next Point: @50<270

Specify next Point: <Pick lower Right corner of ’Lot’ using snap on endpoint>

then right click to leave the polyline command.
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Figure 18: Creating House of yard Drawing

Use Move Command from Modify Menu, to move the House.

Specify to move: <Pick any point of house, whole house will be selected as one entity>

Specify Reference Point: <Pick any lower left corner of house>

Specify Target Point: @10<90

Again use Move Command.

Specify to move: <Pick any point of house, whole house will be selected as one entity>

Specify Reference Point: <Pick any lower left corner of house>

Specify Target Point: @20<-180

Figure 19: Moving House to its position

Now House is created, again save your drawing as - File > Save.

5. Make the Road Layer active

6. Select polyline.

Specify First point: <Pick upper Right corner of ’House’ using Snap on Endpoint>

Specify next Point: @28<0

Specify next Point: @40<90

then right click to leave the polyline command.
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Figure 20: Creating one side of Road

Select the Round Option from Modify menu, to round the turn of Road. Select the radius
of round curve as 10.0 and also check the trim option to trim the intersecion of two lines.

As one side of Road is created. Now create other side of road usinf Mirror command.
Turn ON snap on Entity, Middle, Distance.
Goto Modify > Mirror.

Select the Entity: < select road>

Specify first point of Mirror Line:<pick a point vertical to house’s left edge on right side>

Specify second point of Mirror Line:<pick a point vertical to house’ left edge on left side>

A mirror image appears in preview, set its angle by moving your cursor and then hit click to
stay on that preview. A dialog box will open , select ’keep original’and then click OK. Note:

Figure 21: Creating other side of Road

You can UNDO your mistake anytime.

7. Make the Lawn Layer active

8. Select Spline. Then select the middle of Lot (Diagonal side), using snap on Middle and Inter-
section. Click on middle point, then using Free snap, make a free-hand line with continuous
clicks till it reach the other side of Lot.
Then selecting polyline and using Snap on Endpoint, cover the whole Lawn. Make sure to
Lock all other Layers. So that you can easily pick point of your Lawn Layer. Locking a Layer
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is useful to select the objects overlaying on different layers. Locking makes the layer visible,
but you cant pick that Locked Layer. You can save your drawing now.

Figure 22: Lawn of Yard Drawing

9. Make the Plant Layer active

10. Create a Block in a seperate drawing document and then import it in you drawing. Block is
useful when we have to draw same thing at many places, with same/different scaling factor.
Using Block we create the thing once, and used that block many times.
TO create a Block of Tree, First make a circle, and then a line crossing from its center (using
Snap on Center) and coming smaller towards the outer of circle boundary. Now goto Modify
menu > Rotate.

Select the Entity to rotate: <select line in circle>

Click on run.

Specify Rotation center: <select center of circle>

Specify Reference point: <select center of circle>

Specify Target point: <select center of circle>

Figure 23: Rotate Dialogue box
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Set the rotate angle at 40 degree and keep multiple copies. A tree will be created.
Click on create Block option from Block menu. Select tree as whole entity to create a block.

click on run
select reference point say (0,0)
Adialog box will appear, enter name of your Block (Tree). the click ok. A box will be created
and will listed on Block List which is on right side below the layer List.
Goto Block menu > Save your block as a seprate document. Now, you can insert this block
wherever you want.

To insert the block to your drawing. Open your drawing. Goto to File menu > Import
> Block. Browse you block from your system. when you opened it, you will see the block
appears in Block List.
Click on insert icon on Block List.
Specify any point as a reference point.
click on run.
insert the block where ever you want. you can scale your block by writting scale factor in
box whick appears suring block command. or You can scale from Modify menu > Scale.
Insert the tree block where you want on different scales.

Figure 24: Inserted Tree blocks in Plant Layer

11. Make the Dimension Layer active. Create pond using Ellipse.

12. Make the Fence Layer active

13. Select Polyline to draw Fence. Here snapping will be trickly most used.

Specify First point: <Pick middle ’House’ using Snap on Middle and snap on Entity>

Specify next Point: <To select next point, Restrict vertical and on Entity>

Specify next Point: <Now unselect Restrict Veritcal and select snap on Endpoint>

Specify next Point: <select point using snap on Endpoint>

Specify next Point: <select point using snap on Endpoint>

Specify next Point: <select point using snap on Endpoint>

Specify next Point: <select point by selecting Restrict Orthogonaly, select the point by matching Crosshairs with the first line you created with same command>

Specify next Point: <select last point using snap on Entity>

then right click to leave the polyline command.
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Figure 25: Fense in yard

14. Make the Dimension Layer active
In Dimension Layer, we will add Text and Dimensions both at same layer.
To add Text, Goto Draw menu > Text. A dialogue box will appear, Enter your text, select
the Height of text and angle by which you rotate text. then click OK. Place your text in
drawing area where you want.
To add Dimensions, goto Dimension Menu, select type of dimension. I used Vertical, Hori-
zonal, alligned dimensions in my drawing and also Leder to indicate some part of Drawing.

Figure 26: Drawing of Yard with Dimensioning
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The complete Drawing of Yard:

Figure 27: Drawing of Yard with Dimensioning
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